

<!DOCTYPE html>
<html lang="en-US" class=" html_stretched responsive av-default-lightbox  html_header_top html_logo_center html_bottom_nav_header html_menu_right html_slim html_header_sticky html_header_shrinking html_mobile_menu_phone html_header_searchicon html_content_align_center html_header_unstick_top html_header_stretch html_av-overlay-side html_av-overlay-side-classic html_av-submenu-noclone html_entry_id_151997 ">
<head>
<meta charset="UTF-8" />
<!-- page title, displayed in your browser bar -->
<title>Students call for impeachment of USG president | Daily Trojan</title>

<link rel="icon" href="https://dailytrojan.com/images-dte/favicon.ico" type="image/x-icon">
<!-- add feeds, pingback and stuff-->
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="Daily Trojan RSS2 Feed" href="https://dailytrojan.com/feed/" />
<link rel="pingback" href="https://dailytrojan.com/xmlrpc.php" />

<!-- mobile setting -->
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<!-- Scripts/CSS and wp_head hook -->

	<!-- This site is optimized with the Yoast SEO plugin v14.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Students call for impeachment of USG president | Daily Trojan</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Students call for impeachment of USG president | Daily Trojan" />
	<meta property="og:description" content="Truman Fritz said he is recommitting to diversity, equity and inclusion initiatives and believes he has more to offer in his role as president." />
	<meta property="og:url" content="http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/" />
	<meta property="og:site_name" content="Daily Trojan" />
	<meta property="article:publisher" content="http://facebook.com/DailyTrojan" />
	<meta property="article:published_time" content="2020-06-27T03:20:04+00:00" />
	<meta property="article:modified_time" content="2020-06-27T21:05:07+00:00" />
	<meta property="og:image" content="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?fit=1832%2C961&#038;ssl=1" />
	<meta property="og:image:width" content="1832" />
	<meta property="og:image:height" content="961" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@dailytrojan" />
	<meta name="twitter:site" content="@dailytrojan" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dailytrojan.com/#website","url":"https://dailytrojan.com/","name":"Daily Trojan","description":"University of Southern California","potentialAction":[{"@type":"SearchAction","target":"https://dailytrojan.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?fit=1832%2C961&ssl=1","width":1832,"height":961},{"@type":"WebPage","@id":"http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/#webpage","url":"http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/","name":"Students call for impeachment of USG president | Daily Trojan","isPartOf":{"@id":"https://dailytrojan.com/#website"},"primaryImageOfPage":{"@id":"http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/#primaryimage"},"datePublished":"2020-06-27T03:20:04+00:00","dateModified":"2020-06-27T21:05:07+00:00","author":{"@id":"https://dailytrojan.com/#/schema/person/44f8b5a2e48f0161e7dcd675433af509"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/"]}]},{"@type":["Person"],"@id":"https://dailytrojan.com/#/schema/person/44f8b5a2e48f0161e7dcd675433af509","name":"Mia Speier","image":{"@type":"ImageObject","@id":"https://dailytrojan.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8c8636b6523d26f1da7abe6893b502f0?s=96&d=mm&r=pg","caption":"Mia Speier"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Daily Trojan &raquo; Feed" href="https://dailytrojan.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Daily Trojan &raquo; Comments Feed" href="https://dailytrojan.com/comments/feed/" />

<!-- google webfont font replacement -->

			<script type='text/javascript'>

				(function() {
					
					/*	check if webfonts are disabled by user setting via cookie - or user must opt in.	*/
					var html = document.getElementsByTagName('html')[0];
					var cookie_check = html.className.indexOf('av-cookies-needs-opt-in') >= 0 || html.className.indexOf('av-cookies-can-opt-out') >= 0;
					var allow_continue = true;
					var silent_accept_cookie = document.cookie.match(/aviaCookieSilentConsent/);

					if( cookie_check && ! silent_accept_cookie )
					{
						if( ! document.cookie.match(/aviaCookieConsent/) || sessionStorage.getItem( 'aviaCookieRefused' ) )
						{
							allow_continue = false;
						}
						else
						{
							if( ! document.cookie.match(/aviaPrivacyRefuseCookiesHideBar/) )
							{
								allow_continue = false;
							}
							else if( ! document.cookie.match(/aviaPrivacyEssentialCookiesEnabled/) )
							{
								allow_continue = false;
							}
							else if( document.cookie.match(/aviaPrivacyGoogleWebfontsDisabled/) )
							{
								allow_continue = false;
							}
						}
					}
					
					if( allow_continue )
					{
						var f = document.createElement('link');
					
						f.type 	= 'text/css';
						f.rel 	= 'stylesheet';
						f.href 	= '//fonts.googleapis.com/css?family=Merriweather:300,400,700%7CLora%7CPT+Sans';
						f.id 	= 'avia-google-webfont';

						document.getElementsByTagName('head')[0].appendChild(f);
					}
				})();
			
			</script>
					<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dailytrojan.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=cba1dd68b976ce11303f325a28083269"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://dailytrojan.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 10px;
	line-height: 12px;
	height: 12px;
	background: #ad2210;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='avia-merged-styles-css'  href='https://dailytrojan.com/wp-content/uploads/dynamic_avia/avia-merged-styles-f9b95db4f54e10da8feb503ef0f2e013.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.6.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://dailytrojan.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dailytrojan.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dailytrojan.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://dailytrojan.com/?p=151997' />
<link rel="alternate" type="application/json+oembed" href="https://dailytrojan.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailytrojan.com%2F2020%2F06%2F26%2Fstudents-call-for-impeachment-of-usg-president%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dailytrojan.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailytrojan.com%2F2020%2F06%2F26%2Fstudents-call-for-impeachment-of-usg-president%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.6.4 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gtravjk { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gtravjk img { height:auto; }
	.gtravjk-col { position:relative; float:left; }
	.gtravjk-col:first-child { margin-left: 0; }
	.gtravjk-col:last-child { margin-right: 0; }
	.gtrav-2 { min-width:0px; max-width:300px; }
	.btrav-2 { margin:0px 0px 10px 0px; }
	.gtrav-5 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gtravjk-col, .gtravjk-dyn, .gtravjk-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dailytrojan.com/?wordfence_lh=1&hid=8B0598619C938578BAEE8A95DCB02234');
</script><meta name="generator" content="NextGEN Gallery v3.3.5" />
<meta name="generator" content="NextGEN Gallery Optimizer Basic v2.1.5" />

<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="Daily Trojan RSS2 Feed" href="https://dailytrojan.com/feed/" />
<link rel="pingback" href="https://dailytrojan.com/xmlrpc.php" />
<!--[if lt IE 9]><script src="https://dailytrojan.com/wp-content/themes/enfold/js/html5shiv.js"></script><![endif]-->
<link rel="icon" href="https://dailytrojan.com/images-dte/favicon.ico" type="image/x-icon">

<!-- To speed up the rendering and to display the site as fast as possible to the user we include some styles and scripts for above the fold content inline -->
<script type="text/javascript">'use strict';var avia_is_mobile=!1;if(/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)&&'ontouchstart' in document.documentElement){avia_is_mobile=!0;document.documentElement.className+=' avia_mobile '}
else{document.documentElement.className+=' avia_desktop '};document.documentElement.className+=' js_active ';(function(){var e=['-webkit-','-moz-','-ms-',''],n='';for(var t in e){if(e[t]+'transform' in document.documentElement.style){document.documentElement.className+=' avia_transform ';n=e[t]+'transform'};if(e[t]+'perspective' in document.documentElement.style)document.documentElement.className+=' avia_transform3d '};if(typeof document.getElementsByClassName=='function'&&typeof document.documentElement.getBoundingClientRect=='function'&&avia_is_mobile==!1){if(n&&window.innerHeight>0){setTimeout(function(){var e=0,o={},a=0,t=document.getElementsByClassName('av-parallax'),i=window.pageYOffset||document.documentElement.scrollTop;for(e=0;e<t.length;e++){t[e].style.top='0px';o=t[e].getBoundingClientRect();a=Math.ceil((window.innerHeight+i-o.top)*0.3);t[e].style[n]='translate(0px, '+a+'px)';t[e].style.top='auto';t[e].className+=' enabled-parallax '}},50)}}})();</script><style type='text/css'>
@font-face {font-family: 'entypo-fontello'; font-weight: normal; font-style: normal; font-display: auto;
src: url('https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot');
src: url('https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?#iefix') format('embedded-opentype'), 
url('https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff') format('woff'), 
url('https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf') format('truetype'), 
url('https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg#entypo-fontello') format('svg');
} #top .avia-font-entypo-fontello, body .avia-font-entypo-fontello, html body [data-av_iconfont='entypo-fontello']:before{ font-family: 'entypo-fontello'; }
</style>

<!--
Debugging Info for Theme support: 

Theme: Enfold
Version: 4.6.3.1
Installed: enfold
AviaFramework Version: 5.0
AviaBuilder Version: 0.9.5
aviaElementManager Version: 1.0.1
- - - - - - - - - - -
ChildTheme: Daily Trojan 2015 (DTE)
ChildTheme Version: 1.0
ChildTheme Installed: enfold

ML:128-PU:24-PLA:25
WP:5.4.2
Compress: CSS:all theme files - JS:all theme files
Updates: disabled
PLAu:25
-->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


</head>




<body id="top" class="post-template-default single single-post postid-151997 single-format-standard stretched merriweather lora " itemscope="itemscope" itemtype="https://schema.org/WebPage" >

	<div id='wrap_all'>

	
<header id='header' class='all_colors header_color light_bg_color  av_header_top av_logo_center av_bottom_nav_header av_menu_right av_slim av_header_sticky av_header_shrinking av_header_stretch av_mobile_menu_phone av_header_searchicon av_header_unstick_top av_alternate_logo_active av_header_border_disabled'  role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader" >

		<div  id='header_main' class='container_wrap container_wrap_logo'>
	
        <div class='container av-logo-container'><div class='inner-container'><span class='logo'><a href='https://dailytrojan.com/'><img height='100' width='300' src='https://dailytrojan.com/images-dte/dt14.png' alt='Daily Trojan' title='' /></a></span><ul class='noLightbox social_bookmarks icon_count_6'><li class='social_bookmarks_facebook av-social-link-facebook social_icon_1'><a target="_blank" aria-label="Link to Facebook" href='https://www.facebook.com/DailyTrojan' aria-hidden='true' title='Facebook' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Facebook</span></a></li><li class='social_bookmarks_twitter av-social-link-twitter social_icon_2'><a target="_blank" aria-label="Link to Twitter" href='http://twitter.com/dailytrojan' aria-hidden='true' title='Twitter' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_youtube av-social-link-youtube social_icon_3'><a target="_blank" aria-label="Link to Youtube" href='https://www.youtube.com/user/DailyTrojan' aria-hidden='true' title='Youtube' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Youtube</span></a></li><li class='social_bookmarks_instagram av-social-link-instagram social_icon_4'><a target="_blank" aria-label="Link to Instagram" href='http://instagram.com/dailytrojan' aria-hidden='true' title='Instagram' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Instagram</span></a></li><li class='social_bookmarks_rss av-social-link-rss social_icon_5'><a  target="_blank" aria-label="Link to Rss" href='http://dailytrojan.com/feeds/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Rss'><span class='avia_hidden_link_text'>Rss</span></a></li><li class='social_bookmarks_mail av-social-link-mail social_icon_6'><a  target="_blank" aria-label="Link to Mail" href='http://dailytrojan.com/email-headlines/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Mail'><span class='avia_hidden_link_text'>Mail</span></a></li></ul></div></div><div id='header_main_alternate' class='container_wrap'><div class='container'><nav class='main_menu' data-selectname='Select a page'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><div class="avia-menu av-main-nav-wrap"><ul id="avia-menu" class="menu av-main-nav"><li id="menu-item-94725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-top-level menu-item-top-level-1"><a href="https://dailytrojan.com/news/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">News</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-149643" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://dailytrojan.com/covid-19/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">COVID-19 Updates</span></a></li>
	<li id="menu-item-130499" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/news/campus/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Campus</span></a></li>
	<li id="menu-item-130500" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/news/city/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">City</span></a></li>
	<li id="menu-item-130501" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/news/crime-news/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Crime</span></a></li>
	<li id="menu-item-130503" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/news/housing-news/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Housing</span></a></li>
	<li id="menu-item-131270" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/news/speakers-events/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Speakers and Events</span></a></li>
</ul>
</li>
<li id="menu-item-149637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-2"><a title="COVID-19 Updates" href="https://dailytrojan.com/covid-19/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">COVID-19</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-83895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-3"><a title="Arts &#038; Entertainment" href="https://dailytrojan.com/category/lifestyle/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Arts &#038; Entertainment</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-151291" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://dailytrojan.com/spring-2020-ae-columns/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Columns</span></a></li>
	<li id="menu-item-130775" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/lifestyle/film/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Film</span></a></li>
	<li id="menu-item-130776" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/lifestyle/food/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food</span></a></li>
	<li id="menu-item-130777" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/lifestyle/literature/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Literature</span></a></li>
	<li id="menu-item-130778" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/lifestyle/music/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Music</span></a></li>
	<li id="menu-item-130779" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/lifestyle/theatre/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Theatre</span></a></li>
</ul>
</li>
<li id="menu-item-95180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-top-level menu-item-top-level-4"><a title="Sports" href="https://dailytrojan.com/sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Sports</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-151290" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://dailytrojan.com/spring-2020-sports-columns/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Columns</span></a></li>
	<li id="menu-item-130768" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/baseball-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Baseball</span></a></li>
	<li id="menu-item-130766" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/basketball-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Basketball</span></a></li>
	<li id="menu-item-130764" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/fball/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Football</span></a></li>
	<li id="menu-item-130771" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/golf-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Golf</span></a></li>
	<li id="menu-item-130773" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/womens-lacrosse-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Women&#8217;s Lacrosse</span></a></li>
	<li id="menu-item-131268" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/rowing/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Rowing</span></a></li>
	<li id="menu-item-131265" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/sand-volleyball-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Sand Volleyball</span></a></li>
	<li id="menu-item-130772" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/soccer/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Soccer</span></a></li>
	<li id="menu-item-130770" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/swimming-diving/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Swimming and Diving</span></a></li>
	<li id="menu-item-131267" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/tennis/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Tennis</span></a></li>
	<li id="menu-item-130769" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/track-and-field/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Track and Field</span></a></li>
	<li id="menu-item-131266" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/volleyball/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Volleyball</span></a></li>
	<li id="menu-item-130767" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/sports/waterpolo-sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Water Polo</span></a></li>
</ul>
</li>
<li id="menu-item-83903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-5"><a href="https://dailytrojan.com/category/opinion/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Opinion</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-130505" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://dailytrojan.com/spring-2020-opinion-columns/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Columns</span></a></li>
	<li id="menu-item-130508" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://dailytrojan.com/daily-trojan-editorial-board/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Daily Trojan Editorial Board</span></a></li>
	<li id="menu-item-130506" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://dailytrojan.com/category/opinion/fromtheeditors/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">From the Editors</span></a></li>
	<li id="menu-item-130507" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://dailytrojan.com/category/opinion/lte/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Letters to the Editor</span></a></li>
	<li id="menu-item-151333" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/opinion/alternatestorylines/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Alternate Storylines</span></a></li>
</ul>
</li>
<li id="menu-item-102755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-top-level menu-item-top-level-6"><a href="https://dailytrojan.com/category/classifieds/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Classifieds</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-120798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-7"><a title="Projects" href="https://dailytrojan.com/category/lifestyle/special-topics/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Projects</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-140606" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://dailytrojan.com/special-projects/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Supplement</span></a></li>
	<li id="menu-item-120795" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/media-2/video-media-2/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Video</span></a></li>
	<li id="menu-item-120796" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://dailytrojan.com/category/media-2/podcasts/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Podcasts</span></a></li>
	<li id="menu-item-95728" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://dailytrojan.com/multimedia/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Multimedia</span></a></li>
</ul>
</li>
<li id="menu-item-search" class="noMobile menu-item menu-item-search-dropdown menu-item-avia-special"><a aria-label="Search" href="?s=" rel="nofollow" data-avia-search-tooltip="

&lt;form role=&quot;search&quot; action=&quot;https://dailytrojan.com/&quot; id=&quot;searchform&quot; method=&quot;get&quot; class=&quot;&quot;&gt;
	&lt;div&gt;
		&lt;input type=&quot;submit&quot; value=&quot;&quot; id=&quot;searchsubmit&quot; class=&quot;button avia-font-entypo-fontello&quot; /&gt;
		&lt;input type=&quot;text&quot; id=&quot;s&quot; name=&quot;s&quot; value=&quot;&quot; placeholder='Search' /&gt;
			&lt;/div&gt;
&lt;/form&gt;" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Search</span></a></li><li class="av-burger-menu-main menu-item-avia-special ">
	        			<a href="#">
							<span class="av-hamburger av-hamburger--spin av-js-hamburger">
					        <span class="av-hamburger-box">
						          <span class="av-hamburger-inner"></span>
						          <strong>Menu</strong>
					        </span>
							</span>
						</a>
	        		   </li></ul></div></nav></div> </div> 
		<!-- end container_wrap-->
		</div>
		<div class='header_bg'></div>

<!-- end header -->
</header>
	
	<div id='main' data-scroll-offset='88'>

	
		<div class='container_wrap container_wrap_first main_color sidebar_right'>

			<div class='container template-blog template-single-blog '>

				<main class='content units av-content-small alpha  av-blog-meta-comments-disabled av-blog-meta-html-info-disabled'  role="main" itemscope="itemscope" itemtype="https://schema.org/Blog" >

                    
<article class='post-entry post-entry-type-standard post-entry-151997 post-loop-1 post-parity-odd post-entry-last single-big with-slider post-151997 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-main-feature category-news tag-natalie-oganesyan tag-news tag-summer2020-2 tag-usg-2'  itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost" ><h1 class='post-title entry-title '  itemprop="headline" >	<a href='https://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/' rel='bookmark' title='Permanent Link: Students call for impeachment of USG president'>Students call for impeachment of USG president			<span class='post-format-icon minor-meta'></span>	</a></h1><div class="big-preview single-big"><a href="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?fit=1030%2C540&ssl=1" title="Students call for impeachment of USG president"><img width="845" height="321" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=845%2C321&amp;ssl=1" class="attachment-entry_with_sidebar size-entry_with_sidebar wp-post-image" alt="" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=845%2C321&amp;ssl=1 845w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?zoom=2&amp;resize=845%2C321 1690w" sizes="(max-width: 845px) 100vw, 845px" /></a></div><div class='blog-meta'></div><div class='entry-content-wrapper clearfix standard-content'><header class="entry-content-header"><br><span class='post-meta-infos'><span class="blog-author minor-meta">By <span class="entry-author-link"  itemprop="author" ><span class="vcard author"><span class="fn">NATALIE OGANESYAN</span></span></span></span><br><time class='date-container minor-meta updated'  itemprop="datePublished" datetime="2020-06-26T20:20:04-07:00" >June 26, 2020</time>&nbsp;<span class="blog-categories minor-meta">in <a href="https://dailytrojan.com/category/featured/" rel="tag">Featured</a>, <a href="https://dailytrojan.com/category/featured/main-feature/" rel="tag">Main Feature</a>, <a href="https://dailytrojan.com/category/news/" rel="tag">News</a> </span><span class="text-sep text-sep-cat"></span></span></header><div class="entry-content"  itemprop="text" >
<p>A petition calling for Undergraduate Student Government President Truman Fritz’s impeachment began circulating Friday following the publication of several posts on Instagram account @black_at_usc claiming that he engaged in racial misconduct and microaggressive behavior toward Black students. The petition has accrued 925 signatures to date.</p>



<p>As of publication, two posts allege that Fritz tried to garner more votes from Black students by asking them to talk to “their people.” Two more posts outlined how Fritz’s jokes about students of color and his grouping of them into a monolith has made people uncomfortable. One of these posts stated that the president joked about the “pains of being white.”</p>



<p>Abeer Tijani, a rising senior majoring in global health who created the petition, posted screenshots of her email to Fritz calling for him to step down from his position, contending that a true commitment to dismantling racism on campus would lead him to look within himself and acknowledge the need for new USG leadership.</p>



<p>“I have seen you insert yourself into spaces on campus that are working to dismantle the deeply-rooted racism that seeps into every corner of our campus, and I have also witnessed USG release cosmetic, almost farcical statements of allyship and commitments to do better,” Tijani wrote. “You are the face of USG and it is your duty to uphold the mission and values of the organization even — and perhaps especially — when you are ‘off-duty.’”</p>



<p>Tijani wrote that she felt “vehemently uncomfortable” with Fritz and USG Vice President Rose Ritch, retaining their posts and that stepping down would be more beneficial than attempting to ‘make amends’ with the Black student body.</p><div class="gtravjk gtravjk-5"><div class="gtravjk-single atravjk-103"><a class="gofollow" data-track="MTAzLDUsMSw2MA==" href="https://gsep.pepperdine.edu/doctorate-learning-technologies/"><img src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/DELT-Jul-728x90-1.png" /></a></div></div>



<p>“In this instance, anti-racism requires taking the first step in dismantling the system that you actively benefit from and help to maintain,” Tijani wrote. “Ask yourself: if I choose to keep this post, am I doing it with a commitment to anti-racism in mind? Or is it for the prestige, the privilege, or your pride?”</p>



<p>The email also stated that no Black student worked on Fritz’s presidential campaign and that the president chose not to amplify the voices of Black students before the resurgence of the Black Lives Matter movement and nationwide protests, indicating that anti-racism advocacy is not a priority for him. Tijani stated she contacted the USG Senate to accelerate the impeachment process.</p>



<p>“My eyes, and the eyes of the entire student body, are on you Truman,” she wrote.</p>



<p>According to USG bylaws, an undergraduate student may file a complaint against the president with the Speaker of the Senate, Gabe Savage. The complaint must outline specific violations of the USG constitution, bylaws or code of ethics.&nbsp; From there, the speaker notifies the president, and the Senate must vote within 10 academic days whether to proceed with disciplinary action by a two-thirds majority. If Fritz is voted to be impeached, the Senate will then vote to remove him from office by a five-sixths majority.&nbsp;</p>



<p>In a statement on Instagram, Fritz did not address calls for his impeachment but instead wrote that he recognized he is a “person of privilege.” Fritz added it is “not the time for white people to defend themselves” and apologized to the people who came forward with allegations of his racist acts.&nbsp;</p>



<p>“I would argue in saying I’m really not trying to defend myself, I&#8217;m not trying to make excuses for my actions,” said Fritz in an interview with the <em>Daily Trojan</em>. “I&#8217;m not trying to redirect the blame of the burden that I have to bear. And I&#8217;m trying to find the solution too — I&#8217;m not just saying, &#8216;OK, forget the past, it&#8217;s over.&#8217; I&#8217;m really focused on finding an amicable resolution to this entire thing and again I really want to be part of the solution that we find, not only as a student government, as a presidency, but also as an entire community to everything that our students of color face.”</p>



<p>The Black Student Assembly will not be making any statements or calls of action without speaking with the Black undergraduate student community, BSA Co-director Jaya Hinton said in a message to the <em>Daily Trojan</em>.</p>



<p>“The three directors believe that because Truman has been working very closely with us and providing the resources we’ve needed in our recent advocacy efforts, that we have the chance to educate him and help him grow rather than dismiss him immediately,” the message read. “However, we will consult with our community and ultimately decide on what is best and most aligns with our majority.”</p>



<p>USG senators are deliberating whether impeachment proceedings will take place, a statement published on USG&#8217;s Instagram story read. Students were encouraged to contact Chief Diversity Officer Vivian Ren to share experiences or concerns regarding the student government.&nbsp;</p>



<p>In the Instagram statement, Fritz asked for students to call him out and educate him by sharing their experiences, stating that he will listen to them.&nbsp;</p>



<p>“I know I am part of the system,” he wrote. “I know it will be a heavy lift, but I am driven to be better. I will make mistakes because I am not perfect. I am calling on everyone, including myself, to keep me accountable. I have always tried to be intentional in how I engage in allyship, and I ask for others to help as I educate myself.”</p>



<p>Fritz also stated that he is reavowing his commitment to equity at USC, announcing a series of conversations with cultural organizations about what Black and Indigenous students and students of color need to succeed, an internal educational program and book club with the USG Executive Cabinet and the creation of a broader coalition of student organizations to support diversity, equity and inclusion initiatives.</p>



<p>In the interview, Fritz acknowledged he has to hold himself accountable for his actions, whether or not he can recall them, as they negatively impacted the campus community and student body.&nbsp;</p>



<p>“I do take responsibility for the fact that these people did feel like they needed to voice up and they feel like they needed to make sure that their experience was heard and acknowledged and that I responded to it, and I really do apologize that they went through something like that and that I helped perpetuate the microaggressions and systemic racism that we see every day,” Fritz said. “I don&#8217;t want to be part of that.”</p>



<p><em>Shaylee Navarro and Raymond Rapada contributed to this report.</em></p>



<p><em>This article was updated June 26 at 9:45 p.m. to include a statement from the Undergraduate Student Government</em>.</p>



<p><em>This article was updated June 26 at 10:20 p.m. to identify the creator of the petition.</em></p>



<p><em>This article was updated June 27 at 2:05 p.m. to reflect the current signature count.</em></p>
</div><footer class="entry-footer"><span class="blog-tags minor-meta"><strong>Tags:</strong><span> <a href="https://dailytrojan.com/tag/natalie-oganesyan/" rel="tag">#natalie-oganesyan</a>, <a href="https://dailytrojan.com/tag/news/" rel="tag">#news</a>, <a href="https://dailytrojan.com/tag/summer2020-2/" rel="tag">#summer2020</a>, <a href="https://dailytrojan.com/tag/usg-2/" rel="tag">#usg</a></span></span><div class='av-share-box'><h5 class='av-share-link-description av-no-toc '>Share this entry</h5><ul class='av-share-box-list noLightbox'><li class='av-share-link av-social-link-facebook' ><a target="_blank" aria-label="Share on Facebook" href='https://www.facebook.com/sharer.php?u=https://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/&#038;t=Students%20call%20for%20impeachment%20of%20USG%20president' aria-hidden='true' title='' data-avia-related-tooltip='Share on Facebook' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Share on Facebook</span></a></li><li class='av-share-link av-social-link-twitter' ><a target="_blank" aria-label="Share on Twitter" href='https://twitter.com/share?text=Students%20call%20for%20impeachment%20of%20USG%20president&#038;url=https://dailytrojan.com/?p=151997' aria-hidden='true' title='' data-avia-related-tooltip='Share on Twitter' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Share on Twitter</span></a></li><li class='av-share-link av-social-link-whatsapp' ><a target="_blank" aria-label="Share on WhatsApp" href='https://api.whatsapp.com/send?text=https://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/' aria-hidden='true' title='' data-avia-related-tooltip='Share on WhatsApp' rel="noopener noreferrer"><span class='avia_hidden_link_text'>Share on WhatsApp</span></a></li><li class='av-share-link av-social-link-mail' ><a  aria-label="Share by Mail" href='mailto:?subject=Students%20call%20for%20impeachment%20of%20USG%20president&#038;body=https://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='' data-avia-related-tooltip='Share by Mail'><span class='avia_hidden_link_text'>Share by Mail</span></a></li></ul></div></footer><div class='post_delimiter'></div></div><div class='post_author_timeline'></div></article><div class='single-big'></div><div class ='related_posts clearfix av-related-style-full'><h5 class='related_title'>You might also like</h5><div class='related_entries_container '><div class='av_one_half no_margin  alpha relThumb relThumb1 relThumbOdd post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/06/16/letter-to-the-editor-sca-has-failed-to-address-systemic-racism/' class='relThumWrap noLightbox' title='Letter to the Editor: SCA has failed to address systemic racism'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="Opinion" srcset="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=36%2C36&amp;ssl=1 36w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?zoom=2&amp;resize=180%2C180 360w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>Letter to the Editor: SCA has failed to address systemic racism</strong>	</a></div><div class='av_one_half no_margin   relThumb relThumb2 relThumbEven post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/05/29/vice-provost-for-graduate-programs-to-step-down/' class='relThumWrap noLightbox' title='Vice Provost for Graduate Programs to step down'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="News" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?resize=180%2C180&amp;ssl=1 180w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?zoom=2&amp;resize=180%2C180 360w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>Vice Provost for Graduate Programs to step down</strong>	</a></div><div class='av_one_half no_margin   relThumb relThumb3 relThumbOdd post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/06/03/usc-athletics-dismisses-booster-over-racist-tweets/' class='relThumWrap noLightbox' title='USC Athletics dismisses booster over racist tweets'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="mikebohn" srcset="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?resize=36%2C36&amp;ssl=1 36w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?zoom=2&amp;resize=180%2C180 360w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/mikebohn.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>USC Athletics dismisses booster over racist tweets</strong>	</a></div><div class='av_one_half no_margin   relThumb relThumb4 relThumbEven post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/06/09/letter-to-the-editor-why-greek-life-should-be-abolished/' class='relThumWrap noLightbox' title='Letter to the Editor: Why Greek life should be abolished'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="Opinion" srcset="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=36%2C36&amp;ssl=1 36w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?zoom=2&amp;resize=180%2C180 360w, https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Opinion.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>Letter to the Editor: Why Greek life should be abolished</strong>	</a></div><div class='av_one_half no_margin   relThumb relThumb5 relThumbOdd post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/06/19/usc-celebrates-juneteenth-with-poetry-dance-and-reflection/' class='relThumWrap noLightbox' title='USC celebrates Juneteenth with poetry, dance and reflection'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="News" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=180%2C180&amp;ssl=1 180w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?zoom=2&amp;resize=180%2C180 360w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>USC celebrates Juneteenth with poetry, dance and reflection</strong>	</a></div><div class='av_one_half no_margin  omega relThumb relThumb6 relThumbEven post-format-standard related_column'>
	<a href='https://dailytrojan.com/2020/05/26/usc-locks-down-several-notable-recruiting-classes-for-2020/' class='relThumWrap noLightbox' title='USC locks down several notable recruiting classes for 2020'>
	<span class='related_image_wrap' ><img width="180" height="180" src="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?resize=180%2C180&amp;ssl=1" class="attachment-square size-square wp-post-image" alt="" title="ClareMckee" srcset="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?resize=36%2C36&amp;ssl=1 36w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?resize=180%2C180&amp;ssl=1 180w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?zoom=2&amp;resize=180%2C180 360w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/05/ClareMckee.jpg?zoom=3&amp;resize=180%2C180 540w" sizes="(max-width: 180px) 100vw, 180px" />	<span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span>	</span><strong class='av-related-title'>USC locks down several notable recruiting classes for 2020</strong>	</a></div></div></div>


	        	
	        	
<div class='comment-entry post-entry'>


</div>
				<!--end content-->
				</main>

				<aside class='sidebar sidebar_right  smartphones_sidebar_active alpha units'  role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar" ><div class='inner_sidebar extralight-border'><section id="newsbox-2" class="widget clearfix newsbox"><h3 class="widgettitle">Featured Stories</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Students call for impeachment of USG president' href='https://dailytrojan.com/2020/06/26/students-call-for-impeachment-of-usg-president/'><span class='news-thumb '><img width="36" height="36" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=36%2C36&amp;ssl=1" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/News-1.jpg?resize=180%2C180&amp;ssl=1 180w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Students call for impeachment of USG president<span class='news-time'>June 26, 2020 - 8:20 PM</span></strong></a><div class='news-excerpt'><p>Truman Fritz said he is recommitting to diversity, equity and inclusion initiatives and believes he has more to offer in his role as president.</p>
</div></li><li class="news-content post-format-standard"><a class='news-link' title='SDA dean resigns after previous relationship with student is made public' href='https://dailytrojan.com/2020/06/25/sda-dean-resigns-after-previous-relationship-with-student-is-made-public/'><span class='news-thumb '><img width="36" height="36" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=36%2C36&amp;ssl=1" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=180%2C180&amp;ssl=1 180w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>SDA dean resigns after previous relationship with student is made public<span class='news-time'>June 25, 2020 - 8:13 PM</span></strong></a><div class='news-excerpt'><p>David Bridel announced his resignation in an email to SDA faculty. SCA Dean Elizabeth Daley will assume Bridel’s role on an interim basis.</p>
</div></li><li class="news-content post-format-standard"><a class='news-link' title='LGBTQ online collection connects to pandemic, protests' href='https://dailytrojan.com/2020/06/24/lgbtq-online-collection-connects-to-pandemic-protests/'><span class='news-thumb '><img width="36" height="36" src="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/06/06_23_WONG_Timeline-02-1.jpg?resize=36%2C36&amp;ssl=1" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/06/06_23_WONG_Timeline-02-1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/06/06_23_WONG_Timeline-02-1.jpg?resize=36%2C36&amp;ssl=1 36w, https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/06/06_23_WONG_Timeline-02-1.jpg?resize=180%2C180&amp;ssl=1 180w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>LGBTQ online collection connects to pandemic, protests<span class='news-time'>June 24, 2020 - 1:38 AM</span></strong></a><div class='news-excerpt'><p>The art collection highlights past and present events using LGBTQ archives.</p>
</div></li><li class="news-content post-format-standard"><a class='news-link' title='DACA decision leaves students with momentary relief' href='https://dailytrojan.com/2020/06/24/daca-decision-leaves-students-with-momentary-relief/'><span class='news-thumb '><img width="36" height="36" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=36%2C36&amp;ssl=1" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?w=1000&amp;ssl=1 1000w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=768%2C768&amp;ssl=1 768w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=180%2C180&amp;ssl=1 180w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/06/daca.png?resize=705%2C705&amp;ssl=1 705w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>DACA decision leaves students with momentary relief<span class='news-time'>June 24, 2020 - 1:28 AM</span></strong></a><div class='news-excerpt'><p>Students and pro-immigrant rights groups’ advocacy continue despite verdict. </p>
</div></li></ul><span class="seperator extralight-border"></span></section><section id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><h3 class="widgettitle">Read the Latest Issue</h3><div class="textwidget custom-html-widget"><iframe style="border: 1px solid #777;" src="https://indd.adobe.com/embed/0ce4c281-e857-42f4-944d-4c2423f1b4b9?startpage=1&allowFullscreen=true" width="398px" height="282px" frameborder="0" allowfullscreen=""></iframe>
<h5><a href="https://dailytrojan.com/archives/full-issues/">Read other full issues &gt;&gt;</a></h5>

<hr /></div><span class="seperator extralight-border"></span></section><section id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a href="/housing"><img src="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/04/Housing-Guide-Button.png?w=1500&#038;ssl=1" alt="Housing Guide" data-recalc-dims="1" /></a></div><span class="seperator extralight-border"></span></section><section id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p><a class="twitter-timeline" data-width="390" data-height="800" href="https://twitter.com/dt_covid19?ref_src=twsrc%5Etfw">DT COVID-19 Tweets</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
</div>
		<span class="seperator extralight-border"></span></section><section id="custom_html-2" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><span style="display:inline-block;"><a href="https://indd.adobe.com/view/0ce4c281-e857-42f4-944d-4c2423f1b4b9"><img style="margin-bottom: -9px;" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Download-Issue-Buttons_01.jpg?resize=398%2C128&#038;ssl=1" alt="Print Edition" width="398" height="128" data-recalc-dims="1" /></a><a href="https://adobeindd.com/view/publications/0ce4c281-e857-42f4-944d-4c2423f1b4b9/ybak/publication-web-resources/pdf/Summer_Trojan_Jun_24_-_Full.pdf"><img src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/Download-Issue-Buttons_02.jpg?resize=398%2C114&#038;ssl=1" alt="Download PDF" width="398" height="114" data-recalc-dims="1" /></a></span>
<a href="https://dailytrojan.com/archives/full-issues/">View older full issues...</a></div><span class="seperator extralight-border"></span></section><section id="text-14" class="widget clearfix widget_text">			<div class="textwidget"><!-- Either there are no banners, they are disabled or none qualified for this location! -->
<div class="gtravjk gtravjk-2"><div class="gtravjk-col btravjk-2 atravjk-111"><a class="gofollow" data-track="MTExLDIsMSw2MA==" href="https://www.smartselfstorage.com/self-storage/ca/los-angeles/los-angeles-self-storage/"><img src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/03/LA-Self-Storage-300x250-2020.jpg" /></a></div></div><div class="gtravjk gtravjk-2"><div class="gtravjk-col btravjk-2 atravjk-126"><a class="gofollow" data-track="MTI2LDIsMSw2MA==" href="https://www.thelorenzo.com/information/"><img src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/LORENZO-300x250-06242020-daily-trojan-ad-small-rectangle-RAF.png" /></a></div></div><div class="gtravjk gtravjk-2"><div class="gtravjk-col btravjk-2 atravjk-127"><a class="gofollow" data-track="MTI3LDIsMSw2MA==" href="http://www.calstatela.edu/dtla/strategies-professionals-improvisation-and-acting"><img src="https://i0.wp.com/dailytrojan.com/wp-content/uploads/2020/06/CAL-STATE-LA-Strategies-DailyTrojan-300x250-June2020-4.jpg" /></a></div></div>
<div class="gtravjk gtravjk-3"><div class="gtravjk-single atravjk-100"><a class="gofollow" data-track="MTAwLDMsMSw2MA==" href="https://gsep.pepperdine.edu/doctorate-learning-technologies/"><img src="https://i2.wp.com/dailytrojan.com/wp-content/uploads/2020/06/DELT-Jul-300x250-3.png" /></a></div></div>
</div>
		<span class="seperator extralight-border"></span></section><section id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/dailytrojan" data-widget-id="500351740810510336">Tweets by @dailytrojan</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		<span class="seperator extralight-border"></span></section><section id="avia_socialcount-2" class="widget clearfix avia_socialcount"><a href='http://twitter.com/@dailytrojan/' class='asc_twitter asc_multi_count'><span class='social_widget_icon' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span><strong class='asc_count'>Follow</strong><span>on Twitter</span></a><a href='https://feeds2.feedburner.com/DailyTrojan-rss' class='asc_rss asc_multi_count'><span class='social_widget_icon' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span><strong class='asc_count'>Subscribe</strong><span>to RSS Feed</span></a><span class="seperator extralight-border"></span></section><section id="avia_fb_likebox-2" class="widget clearfix avia_fb_likebox"><div class='av_facebook_widget_wrap ' ><div class="fb-page" data-width="500" data-href="https://www.facebook.com/DailyTrojan" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"></div></div></div><span class="seperator extralight-border"></span></section><section id="text-13" class="widget clearfix widget_text">			<div class="textwidget"><h4><a href="https://dailytrojan.com/feedback/tips/">News Tips ></a></h4></div>
		<span class="seperator extralight-border"></span></section></div></aside>

			</div><!--end container-->

		</div><!-- close default .container_wrap element -->


						<div class='container_wrap footer_color' id='footer'>

					<div class='container'>

						<div class='flex_column av_one_fifth  first el_before_av_one_fifth'><section id="nav_menu-3" class="widget clearfix widget_nav_menu"><div class="menu-bottom-menu-column-1-container"><ul id="menu-bottom-menu-column-1" class="menu"><li id="menu-item-134190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134190"><a href="http://dailytrojan.com/general-information/">About</a></li>
<li id="menu-item-134191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134191"><a href="https://dailytrojan.com/info/">Information and Policies</a></li>
<li id="menu-item-134192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134192"><a href="https://dailytrojan.com/daily-trojan-editorial-board/">Editorial Board</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fifth  el_after_av_one_fifth  el_before_av_one_fifth '><section id="nav_menu-4" class="widget clearfix widget_nav_menu"><div class="menu-bottom-menu-column-2-container"><ul id="menu-bottom-menu-column-2" class="menu"><li id="menu-item-134194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134194"><a href="https://dailytrojan.com/ads/">Ads</a></li>
<li id="menu-item-134195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134195"><a href="https://dailytrojan.com/apply/">Apply</a></li>
<li id="menu-item-137752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137752"><a href="https://dailytrojan.com/history/">History</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fifth  el_after_av_one_fifth  el_before_av_one_fifth '><section id="nav_menu-5" class="widget clearfix widget_nav_menu"><div class="menu-bottom-menu-column-3-container"><ul id="menu-bottom-menu-column-3" class="menu"><li id="menu-item-134196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134196"><a href="https://dailytrojan.com/map/">Map</a></li>
<li id="menu-item-134197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134197"><a href="https://dailytrojan.com/feedback/">Contact Us</a></li>
<li id="menu-item-134198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134198"><a href="https://dailytrojan.com/archives/">Archives</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fifth  el_after_av_one_fifth  el_before_av_one_fifth '><section id="nav_menu-6" class="widget clearfix widget_nav_menu"><div class="menu-bottom-menu-column-4-container"><ul id="menu-bottom-menu-column-4" class="menu"><li id="menu-item-134199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134199"><a href="https://dailytrojan.com/email-headlines/">Subscribe via Email</a></li>
<li id="menu-item-134200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134200"><a href="https://dailytrojan.com/feeds/">Subscribe via RSS</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fifth  el_after_av_one_fifth  el_before_av_one_fifth '><section id="nav_menu-7" class="widget clearfix widget_nav_menu"><div class="menu-bottom-menu-column-5-container"><ul id="menu-bottom-menu-column-5" class="menu"><li id="menu-item-83959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83959"><a href="https://dailytrojan.com/help/">Help</a></li>
<li id="menu-item-83960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83960"><a href="https://dailytrojan.com/site-map/">Site Map</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div>

					</div>


				<!-- ####### END FOOTER CONTAINER ####### -->
				</div>

	


			

			
				<footer class='container_wrap socket_color' id='socket'  role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter" >
                    <div class='container'>

                        <span class='copyright'>© University of Southern California/Daily Trojan. All rights reserved. </span>

                        <nav class='sub_menu_socket'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><div class="avia3-menu"><ul id="avia3-menu" class="menu"><li id="menu-item-138174" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-top-level menu-item-top-level-1"><a href="https://dailytrojan.com/2019/04/08/classifieds-april-8-2019/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Classifieds – April 8, 2019</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
</ul></div></nav>
                    </div>

	            <!-- ####### END SOCKET CONTAINER ####### -->
				</footer>


					<!-- end main -->
		</div>
		
		<a class='avia-post-nav avia-post-prev with-image' href='https://dailytrojan.com/2020/06/25/sda-dean-resigns-after-previous-relationship-with-student-is-made-public/' >    <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span>    <span class='entry-info-wrap'>        <span class='entry-info'>            <span class='entry-title'>SDA dean resigns after previous relationship with student is made public</span>            <span class='entry-image'><img width="80" height="80" src="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=36%2C36&amp;ssl=1 36w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?resize=180%2C180&amp;ssl=1 180w, https://i1.wp.com/dailytrojan.com/wp-content/uploads/2020/02/BreakingNews.jpg?zoom=3&amp;resize=80%2C80 240w" sizes="(max-width: 80px) 100vw, 80px" /></span>        </span>    </span></a><!-- end wrap_all --></div>

<a href='#top' title='Scroll to top' id='scroll-top-link' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Scroll to top</span></a>

<div id="fb-root"></div>

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/js/avia.js?ver=4.6.3.1'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/js/shortcodes.js?ver=4.6.3.1'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/countdown/countdown.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/gallery/gallery.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/icongrid/icongrid.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/iconlist/iconlist.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/image_hotspots/image_hotspots.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/magazine/magazine.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/portfolio/isotope.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries/masonry_entries.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/notification/notification.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/numbers/numbers.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/progressbar/progressbar.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow-video.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider/slideshow_layerslider.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/tabs/tabs.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/testimonials/testimonials.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/timeline/timeline.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/video/video.js?ver=cba1dd68b976ce11303f325a28083269'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dailytrojan.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/dailytrojan.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/js/avia-snippet-megamenu.js?ver=4.6.3.1'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/js/avia-snippet-sticky-header.js?ver=4.6.3.1'></script>
<script type='text/javascript' src='https://dailytrojan.com/wp-content/themes/enfold/js/avia-snippet-widget.js?ver=4.6.3.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script>

 <script type='text/javascript'>
 /* <![CDATA[ */  
var avia_framework_globals = avia_framework_globals || {};
    avia_framework_globals.frameworkUrl = 'https://dailytrojan.com/wp-content/themes/enfold/framework/';
    avia_framework_globals.installedAt = 'https://dailytrojan.com/wp-content/themes/enfold/';
    avia_framework_globals.ajaxurl = 'https://dailytrojan.com/wp-admin/admin-ajax.php';
/* ]]> */ 
</script>
 
 
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script>
				<script type='text/javascript'>
			
				(function() {
					
					/*	check if google analytics tracking is disabled by user setting via cookie - or user must opt in.	*/
					var html = document.getElementsByTagName('html')[0];
					var cookie_check = html.className.indexOf('av-cookies-needs-opt-in') >= 0 || html.className.indexOf('av-cookies-can-opt-out') >= 0;
					var allow_continue = true;
					var silent_accept_cookie = document.cookie.match(/aviaCookieSilentConsent/);

					if( cookie_check && ! silent_accept_cookie )
					{
						if( ! document.cookie.match(/aviaCookieConsent/) || sessionStorage.getItem( 'aviaCookieRefused' ) )
						{
							allow_continue = false;
						}
						else
						{
							if( ! document.cookie.match(/aviaPrivacyRefuseCookiesHideBar/) )
							{
								allow_continue = false;
							}
							else if( ! document.cookie.match(/aviaPrivacyEssentialCookiesEnabled/) )
							{
								allow_continue = false;
							}
							else if( document.cookie.match(/aviaPrivacyGoogleTrackingDisabled/) )
							{
								allow_continue = false;
							}
						}
					}

					if( ! allow_continue )
					{ 
						window['ga-disable-UA-1254752-1'] = true;
					}
				})();
			</script><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-1254752-1', 'auto');
  ga('send', 'pageview');

</script>

<script>
  !function(g,s,q,r,d){r=g[r]=g[r]||function(){(r.q=r.q||[]).push(
  arguments)};d=s.createElement(q);q=s.getElementsByTagName(q)[0];
  d.src='//d1l6p2sc9645hc.cloudfront.net/tracker.js';q.parentNode.
  insertBefore(d,q)}(window,document,'script','_gs');

  _gs('GSN-636139-M');
</script><script type='text/javascript' src='https://stats.wp.com/e-202026.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'169456377',post:'151997',tz:'-7',srv:'dailytrojan.com'} ]);
	_stq.push([ 'clickTrackerInit', '169456377', '151997' ]);
</script>
</body>
</html>
